About the Netlify Integration category

Create a new topic with the questions or feedback you have about the Algolia Crawler for Netlify.

2 Likes

FYI - this works for me in Google Chrome 85.0.4183.121 (Official Build) (64-bit) and 86.0.4240.75 (Official Build (x86_64) on macOS Catalina 10.15.7

Cannot access Crawler Admin page in Firefox and Safari on macOS

I’ve been trying to test this, but get a blank screen when redirected from the plugin docs on Netlify to https://crawler.algolia.com/admin/netlify

I’ve turned off content blocking for Netlify, GitHub (docs), and Algolia domains.

I’ve tried logging in with email/password and with “Sign in with Netlify”; neither worked.

I’ve disconnected from all VPNs.

In the browser console, I get the following error when connecting to any page in the crawler.algolia.com domain (which redirects me to /admin/):

SyntaxError: invalid regexp group

OS: macOS Catalina 10.15.7
Browsers:

  • Firefox 68.11.0esr (64-bit)
  • Safari 14.0 (15610.1.28.1.9, 15610)

Hey Rob,

Thanks for the report, I can reproduce the issue in Safari.
We’ll take a look at the issue and fix it as soon as possible.

Sorry for inconvenience

1 Like

Hi! Loved the experience of the onboarding, but I found an issue related to the fact that my netlify site has a custom domain. Will it be possibile in the future to allow custom domains to be crawled?

Hey @rob.sutter,

A fixed has landed in production, can you try again?

The issue was coming from the monaco-editor dependency that was using an unsupported regex in Safari (cf: stackoverflow)
A github issue has been raised to the appropriate team: https://github.com/microsoft/monaco-editor/issues/2179

Thanks again for taking the time to report the issue, much appreciated :pray:

1 Like

Hi @samuel.bodin - thanks for the quick fix!

Safari

All good on Safari here.

Firefox

Functionality is in place in Firefox but I get a weird font/icon display bug on the dashboard. Not sure if that’s me/content blockers or something specific to Firefox. Screenshot attached.

Only hint in the browser console is the following:

Source map error: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
Resource URL: https://crawler.algolia.com/admin/bundles/app.01fe6782e6008754bfce.js?01fe6782e6008754bfce
Source Map URL: app.01fe6782e6008754bfce.js.map

hey @rob.sutter

We finally understood the issue with the icon, it’s due to SVG not supported rem unit in Firefox < 68.
Unfortunately we don’t support that browser anymore.
I’ll recommend, if possible, to upgrade to v78sre

Sorry for the inconvenience

1 Like