After upgrade from 1.6.0 (magento 1) to latest 1.14 getting error: Please provide an API key. Usage: algoliasearch(applicationID, apiKey, opts)

As subject says, after upgrade of Algolia module, magento 1 (1.9.3.9) I get this error on every page load to console.

https://sentry.io/share/issue/f9039b3b23c64c89b258d3193ccd5347/

Tracing the code in chrome dev tools, I can clearly see the key IS defined…and also search works in frontend

Selection_555

Any ideas?

Solved.

Complete uninstall of all algolia module. Removed any ref to algolia in any file
re-install from scratch, re-apply custom theme changes.

I suspect old 1.6 file in theme was issue.