Algolia and adblockers

Hi there,
We are experiencing issues with customers who have an adblocker. They are not able to click on any of the search results in our store. How can we overcome this issue?

Do you know the name of the adblocker extension and which browser it is installed on by any chance?

Thanks for your reply! It happens in all browsers, and we know at least 3 adblockers: Adblocker plus, AdGuard and uBlock Origin.

I use uBlock Origin as well as adblocking in Firefox and have never spotted an issue or had one reported. Have you amended the markup or class names at all? I know adblock can be sensitive to certain keywords.

We haven’t changed anything yet. What do you recommend?

Are you sure it’s not a content security policy or something blocking the request and not an adblocker? The next step might be to setup a version on [codesandbox.io](https:// codesandbox.io) that you can post on here. That way I can check your implementation.

You can use the API keys from this sandbox if you would prefer to keep your data and keys out of a public link https://codesandbox.io/s/ojb6m9nb

We got this feedback from quite a few customers. We cannot replicate a Shopify site on [codesandbox.io]. Maybe you can reproduce the issue? Please go to https://nl.pit-pit.com/ in Chrome → Add Adblocker Plus → Go to Adblocker Plus settings → Enable: Block additional tracking (By default its disabled) → Search for a product and try to click on any of the products in search result list.

Fortunately, I also have a Shopify store running Algolia with the default implementation, so I could cross-check the difference. On mine I have Click Analytics un-ticked under Apps > Algolia > Settings > Analytics. I would try un-ticking “Use click analytics”, in my tests this worked for me.

If you want to have this type of analytics available, I would be tempted to log a support ticket on the Shopify app because it should still function even if the tracking is blocked.

thanks a lot, I will try it!

Unfortunately it did not solve the issue, I tried with Adblocker Plus on Chrome. But thanks for the input! The weird thing is that en.pit-pit.com (our other shop) is not giving any issues, so its limited to nl.pit-pit.com only.

I’m fairly certain it’s related to this script being blocked ​https://cdn.shopify.com/s/files/1/0576/2442/8752/t/15/assets/algolia_analytics.js. If you enable the script in Adblock then the search works. If you’re disabling Analytics through the admin then the script shouldn’t still appear. Do you have any caching on the site that might be preventing the source code from changing?