Didn't show up in frontend

Hi
Please help me have alook, nothings show up in frontend .
http://picgi.com/3xb51ju
http://picgi.com/2eyq5gi
http://picgi.com/ifcu3ne
my site is : www.ec2deals.ru
please kindly help me. thanks!

Hello @keanyongtan,

I’ve checked your website and the DOM selector of your input doesn’t seem to be right. You have it set to .page-header.type16 .block-search input, but it should be #search. Can you change that and see if it helps?

Thanks for reply. i try to change to #search, and the search box cannot click at all. kindly check on my site www.ec2deals.ru

http://picgi.com/0lw5imy
http://picgi.com/t120z3x

try to run these after change still get same results
php bin/magento setup:static-content:deploy
php bin/magento indexer:reindex
php bin/magento cache:flush

do you guide the next solution to solve this problem ? thanks
look forward your reply

Hello,

I checked the input and it appeared when I removed position: relative; from it’s CSS.
Can you make the position: static; important in your CSS to override the relative position?
That should do the trick :slight_smile:

Thanks for reply,
do you know which CSS file to edit ?
is it styles-m.min.css?
thanks!

Yes, that’s the one.

1 Like

issues fixed already. Thanks!
can you guide me how can i set default dropdown/autocomplete and instant search pages, the products default is list as own attritube? just like set default as newest products come first but not relevance come first.
Thanks for helping and appreciate!
regards
Kean