Disable typo tolerance on attributes not working

Disable typo tolerance on attributes is not working.
I have a attribute which is like the SKU number. Query for that SKU number matching exactly should show up one and only one hit. I have added this attribute under “Disable typo tolerance on attributes” in Typo tolerance section on the dashboard (not using API). Still i see returning more than 1 hits that are matching jumbled number of the queried SKU no.