Error after enabling Algolia plugin

Hello there.
After installing Algolia plugin to Magentop 2 I got error on Magento 2 frontend pages:

2 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): Invalid block type: Algolia\AlgoliaSearch\Block\Algolia
Exception #1 (ReflectionException): Class Magento\Search\Helper\Data\Interceptor does not exist

When I tried to update Algolia via composer got this error:
Loading composer repositories with package information Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Conclusion: don’t install algolia/algoliasearch-magento-2 2.0.2
- Conclusion: don’t install algolia/algoliasearch-magento-2 2.0.1
- Conclusion: remove algolia/algoliasearch-client-php 1.28.0
- Installation request for algolia/algoliasearch-magento-2 ^2.0 -> satisfiable by algolia/algoliasearch-magento-2[2.0.0, 2.0.1, 2.0.2].
- Conclusion: don’t install algolia/algoliasearch-client-php 1.28.0
- algolia/algoliasearch-magento-2 2.0.0 requires algolia/algoliasearch-client-php ^2.4 -> satisfiable by algolia/algoliasearch-client-php[2.4.0, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0].
- Can only install one of: algolia/algoliasearch-client-php[2.4.0, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.5.0, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.5.1, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.6.0, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.6.1, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.6.2, 1.28.0].
- Can only install one of: algolia/algoliasearch-client-php[2.7.0, 1.28.0].
- Installation request for algolia/algoliasearch-client-php (locked at 1.28.0) -> satisfiable by algolia/algoliasearch-client-php[1.28.0].

Hi @rudy,

Thanks for posting your question. Can you try removing the extension and the algolia php client from the vendor folder, then clear your composer cache and then try to reinstall the extension?

Once you have done the above, let us know if you still receive the error? Thanks