Error when update angular-instantsearch to v4 and angular V11.2

Hi there!
I had a working version of angular-instantsearch v3 on angular 9, try to update to angular 11 and for that also update angular-instantsearch to v4. Now when running ng serve I get the following error

node_modules/angular-instantsearch/node_modules/instantsearch.js/es/types/widget.d.ts:139:72 - error TS1110: Type expected.

139 declare type SortByDirection = TCriterion | ${TCriterion}:asc | ${TCriterion}:desc;

my angular version is:
Angular: 11.2.14
… animations, common, compiler, compiler-cli, core, forms
… language-service, localize, platform-browser
… platform-browser-dynamic, platform-server, router
… service-worker
Ivy Workspace: No

Package Version

@angular-devkit/architect 0.1102.18
@angular-devkit/build-angular 0.1102.18
@angular-devkit/core 11.2.18
@angular-devkit/schematics 11.2.18
@angular/cdk 11.2.13
@angular/cli 11.2.18
@angular/flex-layout 11.0.0-beta.33
@angular/material 11.2.13
@schematics/angular 11.2.18
@schematics/update 0.1102.18
rxjs 6.6.2
typescript 4.0.8

my instansearch version is:
“algoliasearch”: “^4.13.0”
“angular-instantsearch”: “^4.1.0”
“instantsearch.js”: “^3.7.0”

Hi @giannilupi9

That error makes me think it may be an issue with your typescript compiler being out-of-date. Maybe an older version is pegged in your package files?

If upgrading typescript doesn’t help, I’d jump over to the github repo and cut an issue there:

thank you very much, I was able to solve the problem by upgrading to angular 12 which allows the use of more modern typescript.
Anyway I feel that the documentation is a bit confusing if it says that it accepts angular 10+ being that neither angular 10 nor 11 allow the use of the typescript version required for version 4 of instansearch, perhaps there are subversions that do work with angular 10-11 but i couldn’t find it