Extractors returned 757 records, the maximum is 750

Hello; my Docusaurus project is getting the following error during crawling:

Extractors returned 757 records, the maximum is 750

This issue seems to be covered in the Algolia documentation here: Record Extractor | DocSearch by Algolia

However, even after copy-pasting the recommended resourceExtractor field into my Docusaurus config and then manually retriggering the crawl, I still get the exact same error. Any tips or ideas what I might be doing wrong?

Note that I cannot split up the page in question; it’s a page for a single TypeScript enum, so it wouldn’t make sense to split it up into multiple pages. Thus, I need to find some way to increase the limit.

@j.nesta can you paste your configuration here for this so that our team can take a look? Thank you!

Hey michael. Thanks for the response.
I’m using Algolia from a Docusarus website.
Everything is open source and is located here:
https://github.com/IsaacScript/isaacscript/blob/main/packages/docs/docusaurus.config.js

@michael.king Any idea what I can do to increase the 750 limit?

@j.nesta I agree, your config looks like it matches the suggestion.

Let me drop a message to our DocSearch team and perhaps someone will have an idea internally. It may take a day or two to get a response but I’ll report back once I hear something. Thanks!

@michael.king Any word?

@j.nesta unfortunately no one responded, would you mind submitting an issue over on GitHub so that the team can directly help you? My message may get lost in the chat but the GitHub issues can’t be missed/ignored.