Facet count issue on Wordpress

Hi,

we have Algolia in our Wordpress site and for general searching everything is great, however we use custom taxonomies as facets in our custom search page, but we are getting some odd numbers back. These are all very small numbers so it’s quite noticeable.

On my local version of the site the numbers always seem correct, and indeed on the live site some of them are correct.

I’m sure it’s just something that I haven’t setup correctly, but it shows up when using the Algolia UI to do the search as well, see the image below, there aren’t any more results when I scroll down, but the count states that there are 3?
Indices___Algolia

Hope this makes sense?

Thanks
Derek

Hi @graduates.nrp,

In order to troubleshoot, I have some questions:

  1. Are you using the ‘distinct’ parameter set to true?
  2. If so, are you using ‘facetingAfterDistinct’ set to false or not using it at all?
  3. If so, could you try setting ‘facetingAfterDistinct’ to true?
  4. If none of these work, could you email us at support@algolia.com so that we can take a look at your configuration?

Let us know how this works for you!

Hi,
unfortunately I didn’t set the Algolia search up on the Wordpress install, I know we are using ‘Algolia Instant Search’ as a plugin in Vue, but as I understand it the developer who put it in place had to make some amends to get it working.

I can see the instantsearch.php file in plugins does facetingAfterDistinct set to true, but I am not sure if that is even being used?

Also the results directly on Algolia UI are off, how do I set distinct etc. on there?

Quick thought on this, is there an easy way to turn the numbers off on the facets select boxes? (see image) As the results being returned when I click on them are actually correct, so a quick fix would be to remove the numbers till I can figure out what has happened.

All I can see is that my page is outputting the label of the facet.

Many Thanks
Derek