Highlight results not working for numbers

I can see all of the highlighted results except for a few fields that happen to be numbers. I’ve tried adding them to highlightable setting but that didn’t work either.