How to set Magento search page result to be the same as the instant search results

We have a Magento 2.3 site and have Algolia installed. The instant search results are working well but if we press return to load the actual search results page, it’s a completely different set of results. I’m assuming these are the default Magento search results instead of the Algolia ones.

Can anyone point me to the setting I’ve missed or documentation for showing Algolia results on the search results page?

Hi @richardmyers

Have you checked this documentation?
Let me know if it’s a different case or if you have any question around it.
Thanks :slight_smile:

Thank you. I did see that but it seemed more complicated than I was looking for. I thought there would just be a setting for the Algolia search results to be returned on the standard Magento search results page. Do you have to use that Instant Search results page to get the Algolia provided results?

Hi @richardmyers If sounds like you may not have instantsearch enabled in your Magento Algolia configuration. If you enable instantsearch, it should give you the Algolia results instead of the Magento search results.

Thanks @cindy.cullen. So you do have to use the instant search results page. You can’t just have the Algolia results feed into the standard static Magento search results page?

Hi @richardmyers, it may depend on the version of the Algolia extension you are using. If you are using our latest version 3.0, you will need to use instantsearch. We removed the backend rendering with this version to be compatible with Magento 2.4. To use our back-end rendering features, please install a legacy version and see our Magento 2.4 compatibility documentation for more information.

You may also find this documentation helpful.