How to set the normalization of url uppercase to lowercase

The issue is that my website’s url has lowercase and uppercase,when the algolia runs on my website,it will turn the upper to lower.So it will lead to the that records save the lowercase.When i search,it will take me to the lowercase urls.But the lowercase hasn’t any resources

While true that Algolia is going to normalize your URL (Handling natural languages | Algolia), the index itself should have the correct URL in it and thus, when you search, it should go to the correct URL. I suspect there is something going on with your canonical setting (SEO checklist for InstantSearch.js | Algolia) on your website but I’m not positive about that.

FYI, we have a Discord server, you can reach us there for more interactive support or DMs.