How to upgrade a deprecated docsearch?

Hi, I am completely new to Algolia, so forgive me if I ask naive questions. So the situation is that I am wanting to contribute to an open-source project that uses VuePress to build a website for their documentation. It uses Algolia + DocSearch to index the pages. I learned that the project is using an out-dated version of DocSearch by running the command:

$ npm ls docsearch.js
projectdoc@0.1.0 ~/ProjectDoc
└─┬ vuepress@1.9.7
  └─┬ @vuepress/theme-default@1.9.7
    └── docsearch.js@2.6.3

When I search for docsearch.js in the package-lock.json file I see:

  "node_modules/docsearch.js": {
      "resolved": "https://registry.npmjs.org/docsearch.js/-/docsearch.js-2.6.3.tgz",
      "deprecated": "This package has been deprecated and is no longer maintained. Please use @docsearch/js.",

I want to update/replace this old DocSearch with the new DocSearch, but I don’t know the best way to go about doing this. I can provide more details if needed. I’ve tried a few things which I described the situation on StackExchange here, and on DocSearch by Algolia Discord page, but have not received feedback from either source. Any guidance would be greatly appreciated. Thanks!