How to use Laravel 5.4 with scout and algolia

I’am a software developer, i plan to use algolia as a search engine for my website project. i found more tutorial on how to use algolia with laravel 5.4 (PHP framework) and scout. but get an error message after running the following composer command in my terminal

composer require algolia/algoliasearch-client-php

i get this error

C:\wamp64\www\blog2>composer require algolia/algoliasearch-client-php
Using version ^1.18 for algolia/algoliasearch-client-php
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package fzaninotto/faker (locked at v1.6.0, required as 1.4.) is satisfiable
by fzaninotto/faker[v1.6.0] but these conflict with your requirements or minimum-stability.
Problem 2
- Installation request for fairholm/elasticquent 1.0.
-> satisfiable by fairholm/elasticquen
t[v1.0.0].
- Conclusion: remove laravel/framework v5.4.27
- Conclusion: don’t install laravel/framework v5.4.27
- fairholm/elasticquent v1.0.0 requires illuminate/database ~4.2 -> satisfiable by illuminate
/database[v4.2.1, v4.2.12, v4.2.16, v4.2.17, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2
.8, v4.2.9].
- don’t install illuminate/database v4.2.1|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.12|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.16|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.17|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.2|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.3|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.4|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.5|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.6|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.7|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.8|don’t install laravel/framework v5.4.27
- don’t install illuminate/database v4.2.9|don’t install laravel/framework v5.4.27
- Installation request for laravel/framework (locked at v5.4.27, required as 5.4.*) -> satisf
iable by laravel/framework[v5.4.27].

Installation failed, reverting ./composer.json to its original content.

is there an other way to you alogolia with laravel 5.4??? i need help.

Thanks
Trésor

Hi,

I seems like there is other dependencies trying to update :thinking: These are not related to our client, we don’t require any of that.

I would recommend to delete the vendor directory, the composer.lock file and have a look at your composer.json file. You should probably remove the line about airholm/elasticquent.

Then run composer install.

Let me know if it worked.