I need to define my search parameters, currently the complete word demands me

I need to define my search parameters, currently the complete word demands me, who helps me to define them so that the level of occurrence is approximate and can see my items in my results index. who can help me

thank, so very much

Hi @paulinaramirez - thanks for asking your question. However, it’s difficult to understand exactly what problem you’re having. Could you try to ask again with more detail or any screenshots or code samples? Thanks!

@dzello look at:
I need to filter in my index that has these attributes. Those marked in red are where I need to filter. But I have a problem and is that by typing “YOKO” in my search does not bring me any results. some help.
It seems that it does not take a part of the word, but it seems all complete.
I need if you type a part of the word bring me results for example
“Yoko 205 R16” should bring me the results that contain that.

@dzello
I show you, my ranking.


@paulinaramirez thanks for the extra info. Do you get results when “Remove words if no results” is set to allOptional? (looks like you are trying that from the screenshot)

yeah, This option “remove words if no result” It’s check allOptional, but not running.
Does not work, that option is marked as you say. Then I do not know what it can be. Does not bring results. Entering only “YOKO”. The capital letters influence something?

Hmm. You should be getting results since that attribute is searchable and you are trying with allOptional. The capitalization should not matter. Are you doing the search in the dashboard or from your own code?

Hello, I’m doing the search from the control panel, remember I type “YOKO”, there is a space after yoko and it does not bring me the result of “YOKOHAMA 205 R 16”. If the allOptional option is selected. please help me

with “Yoko” show result, with "Yoko " not show result. This Is the problem.
thanks.

What is happening in this case is that when you add the space it becomes a full word search instead of a prefix search. Because “YOKO” isn’t a separate word, it will only match as a prefix.

okay. Many thanks. I’m waiting for your answer

I updated my answer above with some info I got back. In short, that is an expected behavior. Still there is probably a way to work around it if needed. Can you share a bit more about your use case? Do you expect that the user would add a space even though they see it’s a prefix of a longer word?

How could we improve this?
Is that our client could type only part of the word of the Content

One thing you can do is change the queryType on the dashboard to prefixAll. This will let any word in the query be interpreted as a prefix. However, we generally caution against this because it can create a noisier result set. So make sure to test and see.

Another way to accomplish this is to add a synonym for YOKO=YOKOHAMA, if the number of potential ways the the words will be abbreviated is known in advance.

Let me know if that helps!

1 Like

the problem, It’s Complete. It’s Show Results Thanks

1 Like