I need to get rid of <empty search>

I am trying to get rid of empty search query , I read the docs and applied the solution , but I am still seeing the , below is the code can anyone help me with this . I want to turn it off. if you check the website you can see the code in inspect element

Website: https://www.spastore.com.au/

@michael.king any help will be appreciated thanks

Unable to post code here , its throwing error , you can check the code in the inspect element of the above website

Setting request.params.analytics=false should be enough to keep these searches out of your analytics as described here: How to remove the empty search from analytics | Algolia

However, it doesn’t go back in time to remove any previous empty searches prior to the change.

Is the number still going up? Can you share your code where you included request.params.analytics=false

@chuck.meyer , I am not able to post the code here it’s saying 403 err. I am posting the SS of the code however you can look into the website inspect : spastore.com.au

I have that request.params.analytics=false but that wasn’t woking too so I update to the code in SS
Thanks