Images in indices within algolia is not displaying in the UI

We’re currently using Magento 2.3.1 and in the new feature of “Visual Editor”, our URL appears to be appropriate, as you can see on the right side we’re getting tons of 404 response on Algolia’s GET request. I wonder if it’s our Magento side that is blocking the request and if it is how can we fix the issue.


-> magento’s algolia basic config

I believe url is the URL to your product, not to your product’s image.
You should probably use a field like image or image_url or something like this.

I also have tried that but it’s still not displaying any images.

Hello,

After checking out the URLs of your images, it seems like no protocols are added. That probably doesn’t play well with our thumbnails servers.

Could you try manually adding https: i front of an image and see if that solves the issue?

If so, this is maybe something we could improve on our end.

Hi,
Thank you for the response but unfortunately adding https: in front of an image did not resolve the issue. Here’s a screenshot:

Hi,

Indeed, I think there is an issue on our side on certain prefix patterns.

I’ve logged the problem so it can be addressed.

Thanks for pin pointing the problem.

Thank you for looking into it, will wait for the fixed version