Index sync does not see configuration file after adding prefix

I have multiple environments I want to keep separate indexes for and to do this I’m using SCOUT_PREFIX=dev_. Covered here in the docs

However after importing the model with SCOUT_PREFIX I notice it’s not reading from my existing config file anymore. When I run a sync it says,

 ! [NOTE] No settings found.                                                                 

and a new file with the prefix /scout-dev-*.php is generated.

I don’t want to have to version multiple configuration files for the same index, only difference being the prefix. Is there a way to get indexes with a prefix to use the same config file?