Instantsearch pagination not working properly

Instantsearch pagination, shows the pagination but it doesn’t bring the new page when click to 2,3 … i have set hits per page to 20 . still it doesn’t show anything when click the page number buttons. When click it just append (?q=&idx=movies&p=0&is_v=1) like this. But no next result shows.

Hi, can you provide us a live example that we can work on? Without that it would be hard to help you unfortunately. Also have a look in your browser console for any error.

http://screencast-o-matic.com/watch/cbhDlAXycP

I have made video what i am facing… please have a look kindly. thanks

Hi again, can you do the same (no need to record a video) and open the console before starting? There might be a console error here that could help us.

Here’s how to do it (just putting this for reference, you might already know how to do it): https://webmasters.stackexchange.com/questions/8525/how-do-i-open-the-javascript-console-in-different-browsers

Since it seems to be a completely local website, could you expose it like that:

Give us the url it outputs, so we can have a live preview of your website and debug it.

Thanks

Thanks for your reply. Here you can test my site : http://b55e51a7.ngrok.io

Thanks, it seems like this is an autocomplete.js menu that is running, can you put back an instantsearch page?

I didn’t get your question (can you put back an instantsearch page?). but i removed autocomplete.js and tried without it, and still same. no change.

I am sorry but the live website is not working at all: http://b55e51a7.ngrok.io/

I have no images and so I cannot help you debug it, please can you have a look at the console locally and tell me what happens when you click on page 2?

Let me know if there’s an error message showing up.

http://screencast-o-matic.com/watch/cbhDocXyjC

in this video u can see what happening at console end. this is what i used at pagination.js

var search = instantsearch({
	appId: 'id',
	apiKey: 'key',
	indexName: 'movies',
	urlSync: true
});

search.addWidget(
  instantsearch.widgets.pagination({
    container: '#pagination-container',
    maxPages: 20
  })
);


search.start();

Have you come up with any suggestion? @vvo

Hi, as there are no errors in console, can you publish your test website somewhere for us to check it out asynchronously?

Thanks.

here you will find the whole project. thanks. I hope you will kindly look at it.

@vvo hey, I am also getting the same error, pagination not working properly and there is no console error…how to fix this issue ??

for better understanding, i am providing a video link, just have a look.

Hi to both of you, to better help you out, could you provide a reproducible live example using our example jsFiddle? https://jsfiddle.net/vvoyer/0wm3donb/4/

I can only reliably help you on this subject if you provide me a reproducible live way to see this bug happening.

I hope you can provide this. Thanks.

here my code

https://jsfiddle.net/mdsaif/w2vvhhw9/

Hello that code is not working unfortunately, it seems like something is badly written. Have a look in your developer/browser console

hi there,

have the same issue, trying to use Algolia search in salesforce lightning component.
When click on 2,3,… pages it still stays on first page but just scrolls to the top of page. And console doesn’t output any errors.

could you help me with that?