InstantSearch Swift Package Manager throws Compile error "error: The package product 'AlgoliaSearchClient' requires minimum platform version 14.0 for the iOS platform, but this target supports 12.0 (in target 'InstantSearchCore' from project 'InstantSear"

Hi ,

I am an iOS developer trying to integrate InstantSearch Library via Swift Package Manager.
But, I get the following error while compiling :
“error: The package product ‘AlgoliaSearchClient’ requires minimum platform version 14.0 for the iOS platform, but this target supports 12.0 (in target ‘InstantSearchCore’ from project ‘InstantSearch’)”

PFA Screenshots,


Thanks
Neeraj

Hi @neeraj.raghavendra,

Thanks for bringing this to our attention.

Here is a workaround you may consider, by manually adding https://github.com/algolia/algoliasearch-client-swift to your project, and setting the resolution rule to be exact: 8.19.0.

This can be your interim solution while our engineering team is preparing an update to have it fixed.

1 Like