iOS API Client Podfile Installation Error

Hello, all. I am following the instructions in Readme.me. I added a dependency on InstantSearchClient and added the package the package dependencies.

But when I run pod install I receive this

  • ‘InstantSearchClient-library’ does not specify a Swift version and none of the
    targets ( ‘Pods’ ) integrating it have the ‘SWIFT_VERSION’ attribute set. Please
    contact the author or set the ‘SWIFT_VERSION’ attribute in at least one of the targets that inegrate this pod

I changed the SWIFT_VERSION to 5.0 in the Xcode app same error.

Running version 11.2 of xCode

I have read some items concerning changing the DEFAULT_VERSION here

but when I try to add a custom BUILD_SETTING, it says SWIFT_VERSION already exist which I verified by changing that to 4.2 in xCODE and then other errors were thrown considering the version so I think the Podfile is seeing the version in some way.
It’s just that InstantSearchClient-library is not happy

Hello @saveit2001

Thank you for reporting this!

We have just released the new version of Swift API Client. Try integrate it into your project by adding this line into your podfile:

pod 'AlgoliaSearchClient', '~> 8.0'

Its podspec contains SWIFT_VERSION field, so it must solve your problem.
Let us know if it works.

Oh perfect!!!
I will try that. Thanks

Vladislav Fitc vladislav.fitc Algolia Team
July 21

Hello @saveit2001

Thank you for reporting this!

We have just released the new version of Swift API Client. Try integrate it into your project by adding this line into your podfile:

pod 'AlgoliaSearchClient', '~> 8.0'

Its podspec contains SWIFT_VERSION field, so it must solve your problem.
Let us know if it works.