Is there any way to prevent Page Indices creation permanently in Algolia - magneto

While Indexing , Algolia Page indices created along with product and category indices, but page indices is not using in my store , so is there any way to prevent them to create?

To prevent Algolia from creating page indices during indexing, you can adjust your indexing configuration or mapping settings. Here are some steps you can take:

  1. Review your data structure: Ensure that the page data you don’t want to be indexed is properly structured in a separate section or category that is distinguishable from product and category data. This will help you target specific data for indexing.
  2. Modify your indexing configuration: Algolia indexing typically involves specifying which data fields to index. In your indexing configuration, ensure that you only include the relevant fields for product and category data, excluding any fields Eduk8u related to page data that you want to prevent from being indexed.
  3. Update your mapping settings: Algolia uses mapping settings to define how data is indexed and searched. Check your mapping settings and ensure that any attributes related to page data are excluded or marked as non-indexable. This will prevent Algolia from creating indices for those attributes.
  4. Test your changes: After making the necessary adjustments to your indexing configuration and mapping settings, test the indexing process to verify that the page indices are no longer being created. Monitor the indexing logs or check the search results to ensure that only the desired product and category indices are generated.