Issue after installing Algolia magento 2 module

magento
magento2

#1

Hello, i am stuck with an issue after installing the Algolia Magento 2 module in test server.

We have installed and done what need to be done @SSH.
But the admin is not loading(frontend is fine), its fine when we disable the module.
Also, we are getting below error when reindexing: PHP Fatal error: Uncaught Error: Class ‘AlgoliaSearch\Version’ not found in /…/app/code/Algolia/AlgoliaSearch/Helper/AlgoliaHelper.php

Also above issue is throwing when we re-index as well.

We have enabled module, cleared cache, done setup upgrade etc. Its not getting fixed.


#2

Hello Shyam,

Thanks for asking your question here!

We’ve seen this issue before when the extension wasn’t installed with Composer: https://github.com/algolia/algoliasearch-magento-2/issues/614

Does running composer require algolia/algoliasearch-magento-2 solve your problem?

I hope this helps!

Marie


#3

Thanks Marie for getting me back.

I do have composer. But my doubt is the files i have already added in app/code/.
So is there any issue if i do composer now?
Or can i remove the files from app/code folder and proceed with composer?
Could you please advise on this.

Thanks again Marie for your kind help and expecting a reply asap.


#4

Hello Marie, could you please get back to me regarding my last message?
Please advise, thanks again.


#5

Hi @shyamesellertech,

My apologies for the delayed response. If you installed the module manually, I would try removing the module and then reinstalling it via composer. Composer helps install the necessary dependencies our module requires. You can read more about your issue here:

https://www.algolia.com/doc/integration/magento-2/troubleshooting/general-faq/?language=php#fatal-error-class-algoliasearchversion-not-found-in-algoliahelperphp-on-line-xx

Once you have reinstalled it via composer, don’t forget to run the setup upgrade and clear cache. Let us know if that helps or if you have any further questions.

Best,

Betty