Issue install react-instantsearch into React Native (expo) Project

BUG: I am currently trying to implement react-instantsearch into my React Native Project and am running into a fatal build issue. I am getting an error that I am unable to resolve a module called “crypto”. I tried to get around it by installing crypto into my project but still got the same error. I haven’t seen any reference to an error similar to this on any sources online so I imagine it is a new node dependency

Here is a screenshot of the error that I am getting:

Here is a screenshot of the package.json for my project

I have also tried installing algoliasearch: “^3.24.2” but still get that error.

PS when I take out the react-instantsearch package from my package.json it will build.

Anyone else get this issue? Any ideas how to get around it?

This question is investigated in our github repository. You can follow the resolution here: https://github.com/algolia/react-instantsearch/issues/319

Just closed out both issues. The resolution was to upgrade my Expo version from 17 -> 20