Magento 2.2.6 - Categories are not being indexed!

Hi there,
We are running Magento 2.2.6 with Algolia v1.8.2. New install, went live last week.

Our Algolia application was empty. Upon running the indexer, all the indices are created in our Algolia application. All of them, except the _categories indices, are filled with data.
image

Tried to run the indexer multiple times after that, with:

  • php bin/magento indexer:reindex algolia_products algolia_categories algolia_pages algolia_suggestions algolia_additional_sections
  • php bin/magento indexer:reindex
  • PROCESS_FULL_QUEUE=1 php bin/magento indexer:reindex algolia_queue_runner

Index runner does not indicate any errors.
image

Setup a cron and tried letting that run, same results.

Planning on updating to v1.8.3, but I do not think that will make the difference, since there is nothing in your changelog which would indicate a fix in category index synch.

So… what am I doing wrong?

Hi
Facing the same issue did anyone get update on this?

Thanks,
Karthik

There was no solution or any support from Algolia.
But, around a month later, our category indices started filling automatically without any of us making any changes. So it works now, but unfortunately I have no solution for you.

Can you tell me what is version of Algolia you are using it seems it was an issue with the latest released version 1.11.1?

Am using a version of 1.11.0 in other environment it works cool.

Hi
I fixed the issue by making the Default Category to Enable Now all my categories are indexed to Algolia. Previously my Default Category was disabled.

When we faced the problem we were still on version 1.8.2.
Our live site is running on 1.8.4 now without any problems.

I have just updated my dev environment to version 1.11.1 and it seems to run fine.

Also, I tried disabling the root category and can confirm that once you reindex, your category index will be empty. So your conclusion is right and definitely something to keep in mind when setting up your categories and Algolia!