Magento in the URL

magento CE v2.1.6 - new install - additional-magento-in-the-middle-of-indexed-urls

encountered and applied fix as documented here

My Algolia dashboard indexed URL’s not updated after 6 hours - still contain ref to “bad” URL’s.
Have performed magento indexer:reindex

I just need to give this some time to regenerate, or I need to delete the existing products index in my Algolia Dashboard?

thanks - GARRY

Hello @gsh2000,

every indexed product contains attribute algoliaLastUpdateAtCET where is a date and time of the last reindex of the product.
From this time you can check if the product was already updated or not.

I set Magento Web Server Rewrites to Yes. I executed $ bin/magento indexer:reindex

Still having a “magento” string appear in my Algolia product URL’s…

Anything else I can maybe try?

My site is here
http://telstran.nextmp.net/

thanks - GARRY

Hi, I cannot seem to solve this issue of removing the extra magento string in my URL’s. Can I clear the entire index magento2_default_products in my Dashboard to force an update? I did not set up a cron job so does not seem to be updated. thanks - Garry - USA

Hello Garry,

yes, you can truncate the whole index, but it won’t force an update.
You’ll have to force the update by running a reindex for Algolia products indexer. That you can do with command:
$ bin/magento indexer:reindex algolia_products

If you don’t have the indexing queue enabled it should immediately index your products.