"media" is replaced with "medium"

I have an index that when I search (in the Algolia console) for “media”, it finds and highlights “medium” first and foremost. I have no synonyms for media or medium. I realize the similarities in the word but “media” companies are not “medium” companies. How do I turn this off? media2media4media3media1

Hi @jimb thanks for asking this! I understand the frustration, those terms are definitely not equal in your use case.

This is caused by the ignorePlurals setting: once enabled, it disables plurals for all supported languages.

  • If you don’t want to treat any plural as equivalent to the singular form, simply disable this feature.

  • If you want to ignore plurals but only for a specific, non-english language: set ignorePlurals with the list format: ignorePlurals=["fr"]

  • If you want to ignore all english plurals but media, you can use the advanced syntax:

Advanced syntax enabled, no quotes: plural is ignored

Advanced syntax enabled, with quotes: plural/typos are ignored

You can also change this parameter for a single query by setting it when querying an index.