Missing images in search bar [Magento 1.9]

There are missing images in my search bar, it is showing the broken link picture.

Solutions attempted

  1. Manual reindex of all products
  • Reindex was successful
  1. Tried reindexing at magento admin panel
  • System> index management> reindexed all the available options
  1. Tried running index asynchronously
  • Queue is stuck at 270 products (This is also another issue I’m facing)
  1. Checking image url to see that it is not broken
  • Image works fine
  1. Tried cross-referencing two products of a similar nature, of which one was showing just fine on the search bar and one wasn’t showing
  • Went to manage products to check if they both had the same settings, they did but only one was showing on the search bar
  1. algoliaLastUpdateAtCET:2018-09-24 17:12:100:
  • last update was in September for some reason even though I’ve done re-indexing

I’ve tried reaching out to the email support service which I was told was provided given that I was on the paid plan but Algolia staff seems disinterested in helping.

I’ve tried pretty much everything the offical FAQ has recommended as well as searching through the forums but nothing is working

Hello @tyler1,

the issue is in point 6 of your topic - the product wasn’t reindexed.

Can you disable indexing queue, navigate to this product in Magento administration and just save it?
It’ll reindex the product immediately.

If the product won’t be reindexed:

  • Do you see any error on the page after the save?
  • Can you go through your Magento error and exception logs to see what errors happened in the time of the save?

Thank you!

I’m afraid that doesn’t seem to be the problem, there are no error messages after saving the product.
I’ve done as instructed and this is the current information:

algoliaLastUpdateAtCET:2018-10-03 04:51:50

However the images are still not showing.

[Additional observations]

  • For the products where images are not showing, it seems that the thumbnail url is not working, however, in the magento admin, system>configuration>algolia>images I have changed the settings to be base images (of which the url works fine)

I would appreciate more help on this. I am trying everything I can to no avail