Numeric filters is giving exception : "message": "Invalid syntax for numeric condition:

I have a requirement where the facet is “Frequency Min (GHz)” and its values are numeric (can have decimals). I am trying to apply a numeric filter as below:

numericFilters=Frequency Max (GHz):6

But this is giving an exception:
“Invalid syntax for numeric condition:Frequency Max (GHz):6”
I do not understand what is wrong here. I tried removing the spaces, braces, etc. but still get the exception.
Is the ‘case’ a problem here? Does the name have to be in small case?
I mean I have used numeric filters on facet names that are camelCased.
Can anyone please let me know what am I doing wrong here?

Thanks in advance.

It looks like you are trying to set a lower bound without an upper bound. Syntax should be something like:

numericFilters=["Frequency Max (GHz):6 TO 12"]

or

numericFilters=["Frequency Max (GHz) >= 6"]

Hi @chuck.meyer ,
I tried the latter one and that was still giving the exception.
However, when I tried the first one (giving upper and lower bound) exception was gone but it gave empty hits.

The values of this facet are in decimals like 2.0000, 6.0000, etc…

In Algolia Dashboard also, when I am trying to add this numeric filters (under Query parameters), it shows NO RESULTS FOUND for this facet name.

So I am wondering if the facet name is an issue or its decimal values. Can you please suggest?

I saw your other post about spaces in facet names (and commas). Let me see what.I can dig up.

You are using the search API to filter search results based on the “Price Range (USD)” facet. However, when you try to apply the numeric filter, you encounter an exception with the message: “Invalid syntax for numeric condition: Price Range (USD):100”. Despite attempting various modifications like removing spaces, special characters, and adjusting the case, the exception persists. You wonder if the case sensitivity of the facet name is causing the issue, especially since you have successfully used numeric filters on other facets with different casing. learn more