Process queue - not working

Hi there,
I am trying to re-index data but after clicking on “Process queue” nothing happend… (this button is has link: https://www.printmania.sk/wp-admin/admin.php?page=algolia-indexing#)
I have no error in php error log, and this status in algolia log:
514298 info 2017/04/21 at 01:54:47 Queue is already being handled.
-but there is no update in my aloglia dashboard

Pls check also this gif: https://cl.ly/2Q401d221w2A

Thanks for any help.
Filip

Hi @znamenak,

The issue you are describing is often related to a caching plugin you might use.

Could you tell us if you use a caching plugin and which one?
When you disable that plugin, does it work?

In W3TC for example, you have an option to exclude transients from being cached by indicating a pattern. You can do so by filling ‘algolia’ as the pattern.

Looking forward to help you more,

Hi @rayrutjes,
I’m using the “supercacher” plugin by siteground (also the website is hosted at siteground).

I tried purge the cache, the button is working, but still nothing happend…
It start working on “re-indexing” page XY of XY but after a few seconds it stop working…
Please look here: https://cl.ly/2K0g1V0s3a0T

Thanks,
Filip

I’ve been having the same problem since yesterday. It actually is indexing, but takes a lot of time to load. I am with siteground as well but I do not have their caching turned on.

It took about 12 hours to index what usually takes less than an hour. The only thing I changed was that my WooCommerce was updated. Which makes me ask this question. Are you guys compatible with WC 3.x? I also see that it takes a lot of time to load the first search using the widget. But once on your search results page, it’s fast.

Something is definitely not working right.

@znamenak were you also autoupdated to WC 3.x by Siteground? There is an autoupdate for plugins that runs if a plugin hasn’t been updated and updates are coming in. That’s when everything went wrong with Algolia, and I do not recall getting a compatibility update.

Hoping this can be resolved asap as my client site is live :weary:

Hi @paul1,

That is unfortunate.
We will have a look to see if there is a quick fix we can share.

So far, do you have any errors you could share?

The more info we would get, the faster we could solve this.

Hey @rayrutjes,

There is absolutely nothing in the error log with your name on it. The following though is the most recent error in the log:

[25-Apr-2017 14:21:03 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘icl_object_id’ not found or invalid function name in /home/tonergenerique/public_html/wp-includes/class-wp-hook.php on line 298

Hi @paul1 I didnt updated to WC 3.x. I am using WC 2.3.5.
But at my end, nothing new is indexed, even after few days…

@rayrutjes, is it possible to re-index somehow manually (from your end…) just in this case?

Thanks for any advice,
F

@znamenak I don’t understand the language of your dashboard, but in your first gif, that purple warning on top, this is what I got when Siteground Auto updated WooCommerce without me doing it. It is a process they have on their servers, that is always activated. Can you please triple check your plugins page and see if you’re at 3.x? Also, if you updated to 3.x you cannot go back to previous versions…

I’m just trying to pinpoint if this is from WC 3.0.x or something from siteground, or from Algolia…

Hello @znamenak and @rayrutjes,

My problem is solved, and hoping it can help you solve it. Actually I didn<t do anything special. I cloned the website to a different subdomain. Default theme and no plugins other than WC and Algolia. I also opened a new Algolia Account to make sure I don’t override anything. I tested and it worked amazing. Queue did not stop.

Switched back to our theme, tested, works… Started switching each plugin on, one by one, and testing. It worked every single time.

So to keep it sweet and simple, deactivating all plugins and theme and then switching them back on, one by one, it resolved this issue.

Hope it helps you solve yours as well.

Best of luck!

Paul

FALSE SUCCESS STORY…

I tested once again to make sure my joy was complete, but it failed. Deactivated all plugins and it works. I just can’t pinpoint which plugin Algolia has a conflict with… :frowning:

I promise I won’t bug you guys anymore, but I found it, this time for real. My membership from WPMUDev was canceled due to a dispute in the charge, and I’m guessing their plugins were sending requests to their apis or something. Deactivated their plugins until we resolve it and everything is back to normal.

Maybe check your plugins that use an API, and test without these for now? Just an idea…

Hi @paul1, could you recognise the WPMU plugin by name?
Because I have 56 active plugin, and I don’t know which one is using WPMU API…
And switching off one-by-one is really not the way, what if there is a conflict with two plugins at once? :-//

List of all active plugins: https://www.dropbox.com/s/r5k5mw5imqouhwh/Plugins_Printmania.pdf?dl=0

Or some tool for detection of WPMU API use?

Thanks,
Filip

Hello @znamenak,

The plugin that was causing the slowdown was the Google Analytics plugin by WPMUDev. Now going through your plugin list, I see a few that MIGHT be causing a conflict. I had another search plugin at one point (called Search Everything), and it would cause errors and a bug with the Algolia one. So,

  1. I see you have another search plugin (probably for your filters…). try deactivating this one for testing purposes.

  2. Your Visual Composer is out of date. The current version is 5.1.1 I believe.

I can’t see or think of anything else… I know it might or will take time, but the best thing is using the staging environment from Siteground to test…

Let me know how it goes…

Best regards,

Paul

Hi @paul1,
I tried deactivated all the plugins you mentioned above, but nothing helps.
Even at the staging it didnt work when I deactiveted all the plugins:

Staging: www.staging1.printmania.sk

Algolia won’t work on staging (unless you create a new Algolia Account). Something with the way Siteground sets up their staging. There’s the subdomain, but the website is still without the sub-domain.

What version of Algolia and the WC add-on are you using?

If you’d like, you can set me up on your staging site and I can run some tests and I will let you know exactly what I tested.

Best regards,

Paul

@znamenak did you manage to solve your issue?

not yet @rayrutjes

@paul1 give me your email address, I can provide you with staging login credentials

best,
f

1 Like

@znamenak here is what I did (I’m putting all details here):

Create a hacker plan for the test (so we don’t keep deleting your Index)

I updated your Algolia for WooCommerce from 0.6.0 to 0.8.1
Tested - Did not change anything

My only choice left is updating WooCommerce to the latest version (I see version 2.3.5) and testing. I also see that your theme is out of date which will probably break the look of the store.

Woocommerce updated, with default 2017 theme, still nothing happening. The website ‘‘got in touch’’ with Algolia, I can see it in the Dashboard that the keys are all good.

As I was working, all of a sudden I saw that there were 22 updates required. All your plugins are out of date…

Updated Algolia from 1.6.0 to 2.2.3 (Now all of the active plugins are up to date)
Test - it works.

(Note: I also setup a plugin called WP Sweep to clean up and optimize your database. It helps speed up your site)

I guess the end result is to update both Algolia plugins and test. You can destroy this staging site and recreate to make sure everything works with your current version of WooCommerce (before 3.0) and if everything is good, you’re good to go! Even though I strongly recommend ALWAYS having your theme and plugins completely up to date.

Let me know if updating these 2 plugins worked for you!

Best regards,

Paul

Hi @paul1,
thank you for your help! Everything is working now :slight_smile:

My last question is, where can I find new versions of algolia woocommerce plugin?
For this case I just copied the plugin from staging…

Thanks,
F