React-instantsearch-native not compatible with react native expo v 46?

Upgrading expo from 45 to 46 throws a compatibility error because of react-instantsearch-native.

Using react-instantsearch-native (“6.32.1”) and algoliasearch (“4.14.2”), to search a firestore database and display results into a react native mobile app built with expo (v45).
Trying to upgrade to expo 46 generates the following error:

161 error code ERESOLVE
162 error ERESOLVE unable to resolve dependency tree
163 error
164 error While resolving: undefined@undefined
164 error Found: react@18.0.0
164 error node_modules/react
164 error react@“18.0.0” from the root project
164 error
164 error Could not resolve dependency:
164 error peer react@“>= 16.3.0 < 18” from react-instantsearch-native@6.32.1
164 error node_modules/react-instantsearch-native
164 error react-instantsearch-native@“^6.32.1” from the root project
164 error
164 error Fix the upstream dependency conflict,

Expo 45 is based on react 17.0.2, while expo 46 is built on 18.0.0.

It seems that react-instantsearch-native@6.32.1 might not be compatible with React 18. Is this true?

Any ideas on how to resolve this?

Thanks a lot!