Search box doesn't show

Hello,

I’m a beginner in Magento.

I have installed Algolia like this steps mentionned here https://community.algolia.com/magento/doc/m2/getting-started/

When I active Algolia search, the native search box disappear and there is nothing as search box on my website.

I used the “Search input DOM Selector” but the search box is always as before installing Algolia.

Magento : 2.2.8
Theme : Alothemes Electro
Allow Symlinks : Yes
Website : https://dev.doya.ci

Please can you help me to fix this.

Hello David,

Thank you for contacting us!

I can see that you are using a custom theme for the implementation. Have you followed the instructions given in the documentation to override the topSearch block of the template?

By default, the extension will try to override the topSearch block of the template in use. In case a custom theme is implemented which doesn’t contain the topSearch block, the DOM selector of the search input needs to be changed. This can be achieved by navigating to Stores > Configuration > Algolia Search > Advanced .

With this setting filled, the extension will not try to override the topSearch block, and will only load the scripts necessary. This will require updating of the styles to give the autocomplete menu the desired look and feel.

Let us know how it goes and make sure to include screenshots depicting the issue and/or your configuration in your future messages to help us better understand how to help you solve the issue you are experiencing.

Have a great day!

Best regards,
Benjamin Baron

Hello Benjamin,

Thank you for your help.

As I told you before, I tried to override the topSearch following instructions.

After that, I can see the native search box of the template. But when I try to do some research, It’s like before the installation of Algolia.

I want to get a search box like yours. Maybe the DOM selector is not correct but I tried with all ID that I saw.

Hope you will undersand me well.

Thank you.