Search function disappear after the Algolia installation

Hi Everyone
I want to buy algolia for my couple of websites, but algolia is not working on my site. example site www.officialphonrepair.co.uk , which is based on magento 2 It was professionally installed by developer. Also search bar has disappear.
I have tried reindexing the Algolia search tables. But I got the below error:

Algolia Search Products index has been rebuilt successfully in 00:01:37
Algolia Search Categories indexer process unknown error:
Record at the position 7 objectID=11 is too big size=15410 bytes. Contact us if you need an extended quota
Algolia Search Pages indexer process unknown error:
Record at the position 4 objectID=10 is too big size=18322 bytes. Contact us if you need an extended quota
Algolia Search Suggestions index has been rebuilt successfully in 00:00:00
Algolia Additional Sections index has been rebuilt successfully in 00:00:00

I am not getting any help from algolia as they not replying to my email for this issue. 
There must be somebody out there who has installed successfully on there magento 2 website. 

Any help would be much appreciated. 
Thank you

Hello,

Thanks for taking interest in our product.

It seems that you have objects in your index that are above the size limit (which is usually 10KB).

The error is indicating the objectID and the position of the records that are too big, most of the time this indicate that the records data that are not useful for indexing (images or very large piece of text).

Regarding your magento issues, I take a look at your questions history and it seems that our team is waiting for complementary data on your side or access to your account. Maybe you didn’t receive their answers ? If you did received these mails, please respond to them directly to avoid duplication of support exchanges. While the community forum is a good place for generic technical questions, if we need to go through your application details, you may have concerns about exposing those information.

I hope we’ll be help you solve your problem.

Regards,


Marwan Burelle
Software Engineer @algolia

Thank you so much for quick reply. I did reply but I will send another email to your support team.