Sign up flow with new account

Hi

I’ve tried following the steps in the ‘getting started’ guide a couple of times without success.

I have a Netflify app set up (it’s Hugo site) but no Algolia account.

When I click " Sign in to Algolia with Netlify", I choose to Authorize the application. Then I am presented with an Algolia sign in panel. I follow the link in the top right of the panel saying “I don’t have an account” to create a new Algolia account. When I visit the Dashboard of this new Algolia account and look for the Crawler Admin Console (as-per the guide) I see it has a Padlock and that I need to request a trial of the crawler feature.

The guide suggests that I’ll be able to use the crawler immediately to test it out for the Netlify site, however it seems that crawler is only available to annually-billed customers who need to use at least 100 units per-month?

Any help you can provide is much appreciated. I’m keen to give this a go, as it appears to be a good solution for search on our Hugo site.

Hi Dylan, I’m curious to know more about this screen, after clicking on “Authorize” in Netlify:

Then I am presented with an Algolia sign in panel

This step normally appears when we find an existing Algolia account with the same email than your Netlify account. Could you share a screenshot of it? We know that the message is not very visible and can be overlooked.
You should indeed be redirected directly on the Crawler interface and be able to crawl immediately.

I suspect that if you have clicked on “I don’t have an account”, you have probably created a new account not linked to Netlify, thus with no access to the crawler.

Hi I think this was the mix-up. It seems someone created a testing Algolia account using the same address a while ago. I deleted that account, then tried the guide here again and it has worked.

Thanks. I suppose the only thing that could have helped here is a small alert saying something along the lines of “we’ve found an Algolia account using the email address that matches your Netflify account”.

Good!
Actually there is such message, but as I said, it’s not visible at all as it looks like an error (in red):


If at this step you would have logged in, it would have worked too. We have a ticket in our backlog to make it more obvious.

Anyway, glad that you’re in now, let us know if you face any other issue or if you have feedback! :slightly_smiling_face: