Stop Words doesn't work if it's the last word in a sentence (not followed by space)

Hi,
I am trying to set up stop word for my index.
And it doesn’t seem to work if it’s the last word.
The word is “Edition”, which appears at the end of all my entries, so I am trying to remove it to get less results. But unless I am adding a space after it, it will still display the result.

“product_name Standard Edition” - highlight Edition and use it as part of the query.
"product_name Standard Edition " - removes Edition from the query.

Hi @eliezra236

Until the space has been added, the word Edition is also being treated as a potential prefix. It’s only after you add a space that this word is no longer being considered as a potential prefix, which is why it stops returning results at that point.

You can disable prefix matching on certain attributes, or even entirely if you want, though this would have substantial implications for your search and will result in considerably less search results for your other searches.

Thanks @matthew.bond
But trough this I will have to give up prefix on the entire attirbute, I can’t set an exception just for the word “edition”.
Is there a workaround for that?