Strange Error in IE11

Hey all,

I found out relatively late in a project build that the client needs IE11 support, and I’ve done the things I need to keep IE from freaking out (removing templates, arrow function assignments, etc.) from the code I had, but I’m still getting no response from IE11.There are no errors in the console, but nothing is really firing: the input gets created, but clicking in the input doesn’t clear the fake placeholder, typing into the input doesn’t bring up any results.

After reading through the forum, I tried (at random) to add polyfills that other people suggested for Object.assigns and String.includes to no avail.

Because I’m using both the vanilla JS instantsearch (on every page) and a PHP API Algolia search on the search page, I’m happy to fall back to just overriding the behavior of the instantsearch to create a regular form and submit to the search page, but it seems like I’m so close.

Does InstantSearch work in IE11? is what I’m doing even possible?

Thanks!

Jemal

Hi @jemal
Adding polyfills is indeed the way to go for IE 11 support, however I don’t think you got the right ones.
If you’re using InstantSearch.js V3, the polyfills to add are in our docs: https://www.algolia.com/doc/guides/building-search-ui/installation/js/#browser-support

Can you confirm which version of the InstanstSearch.js you’re using?
Also, if you can send us the error message you have, maybe it will give us a hint on what’s missing!

Thanks for the assistance, @Youcef. I’m using:

.../algoliasearch/3.32.0/algoliasearchLite.min.js
.../instantsearch.js@3.5.3

I just tried adding that polyfill in the document you linked which didn’t change anything.

The strange error I’m getting is no error at all. The InstantSearch half-loads, in that it creates the input.ais-SearchBox-input in the right place, but none of the behaviors work in IE11. Clicking the searchbox doesn’t clear the placeholder text, and typing in the box doesn’t trigger a search.

Jemal

I am doing a bunch of custom things in there - referencing three different indices, custom templating, conjoining multiple searches, scripts for etc. Would it help to post some code or a link?

Would you be able to reproduce this issue on this quick boilerplate ?


It would help to be able to reproduce it in IE 11 on my side.

Hey - thanks for trying to help - I discovered that another script on the page was mucking with focus and somehow that completely prevented instantsesarch from working. I now have it working perfectly in IE11. Thanks again!