Support for custom domain

Continuing the discussion from About the Netlify Integration category:

Hi @andrea
Can you share with us the domain and the netlify site? (You can send in DM if its private).

We have a Feature Request opened in our Github to support custom domain and domain aliases.
Don’t hesitate to +1 and put your feedback there directly :pray:

Sure @samuel.bodin! The website is and the Netlify version is
The prime URL is
It’s really small, I just wanted to play with the plugin to see how Algolia works.

I will surely check and keep an eye on the issue, thanks

Thanks for the quick answer,
Indeed the issue is related to the way we consider canonical.

We crawl the Prime url to be sure to crawl the correct version (if for example you have multiple branches configured). And we ignore all everything that does not begin with

Your have an absolute canonical which is pointing to your main domain and so we can not crawl it.
The temporary fix is to use relative canonical, which is supported by the standard
<link rel="canonical" href="">
<link rel="canonical" href="/">

But as the github issue suggest, we are currently thinking about some kind of hostname aliases so we can more scenario out of the box.

Hope this helps,
Best Regards

Thanks for the reply, I’ve tried the suggestion but while the live version was updated, the html in the DEPLOY_PRIME_URL wasn’t, so I tried to scrap everything and start from the beginning (as explained here but now I am no more able to link again to the same website from - it returns an error 500 stating that it cannot install this site (1332b94b-3ada-46de-8f5c-6637732a78e1)
Should I contact the support?

Hi again andrea,

Sorry about that.
Did by any chance deleted your Algolia application manually?
Because there is one issue when that happen,
it does not automatically unlink your site from Algolia.
That means we won’t let you try to reinstall because it still exists.

We have yet to produce the fix, but it will be hopefully resolved soon.
In the meantime I’ll clean, the link so that you can try again.

Sorry again about that.
Please let us know if that works or if you have furthers issues.

Best Regards

Thanks for the quick reply, I think that I have deleted the application manually.
I’ve tried to link it again without success, I’ll wait for the fix and try again in the next days

Hi @samuel.bodin, sorry to bother you again, but it seems that i am still not able to link my website to the crawler, the issue is the same I mentioned before. As I said in the previous answer I think that I have deleted the Algolia application manually first

I have cleaned all data related to your site,
I think when you retried it was just a temporary issue.

Can you try again? :slight_smile:

@samuel.bodin I’m still getting this issue, I’m not sure how to fix it.

I’m using Netlify DNS to point my custom domain at
My Netlify URL is

When looking in Algolia I’m getting…
IGNORED Extraction (85)
an example URL being ignored is…

I have no hard-coded URLs in my website so I’m unsure why search doesn’t work and pages age being ignore. Any help much appreceiated

Hi @thejuniperstudio. Here your issue is not due to custom domains, it’s because of a wrong canonical redirection. If you look at the details in the URL Inspector, you will see:

Skipped in favor of canonical URL:*

And indeed if I look in the source of the page (be sure to look at the source of the page with the extra / at the end), I can see:

<link data-react-helmet="true" rel="canonical" href="/*"/>

If you can fix this canonical, it should work. Let us know!