Typo tolerance not turning off

Hi, for some reason when I search for “date” in my index it matches “data”.

  • My index has typo tolerance set to false
  • I’m not overriding any defaults from the instantsearch configuration

Does anyone know how to make it so “date” won’t match “data”?

Hi Tony,

The issue you are experiencing comes from the plurals setting. ‘data’ is the plural of ‘date’ in Italian! By default, all languages are supported for this setting, which causes the unexpected behavior.

You can simply disable this feature from your dashboard by setting “ignore plurals” to false. I would instead recommend that you set this setting to the languages you want to support, as this is a very useful feature. You can find more information in the following documentation:

​https://www.algolia.com/doc/guides/textual-relevance/singular-plurals/

​Let me know if that helps!

Thanks! That fixed the problem.

For anyone else reading this who’s using the instant search client, here’s what I did to enable this:

    var search = instantsearch({
        ...
        searchParameters: {
            ignorePlurals: ['en']
        },
        ...
    }