Upgrading from 1.4 to latest Magento plugin

I am having trouble upgrading from v1.4.4 to v1.10 of the Magento plugin

The v1.4 module was installed by an admin who is no longer available and despite various attempts to upgrade / remove and install v1.10 / etc I end up in a mess and unable to access the Algolia control panel under System->Configuration due to the following error

Any suggestions?

fatal error: Class ‘Algolia_Algoliasearch_Block_System_Config_Form_Field_AdditionalSections’ not found

Hello @jon1,

can I ask you how did you try to install the extension? Via Modman or via Magento Connect Manager?
What version of Magento do you use?

Can try to navigate to your-magento-base-folder/app/code/community/Algolia/Algoliasearch/Block/System/Config/Form/Field and see if the file AdditionalSections.php is sitting there and it’s the same as this?

Hi Jan

It’s Magento v1.9.0.1

We tried the install using modman

I’ve tried uninstalling v1.4 and installing v1.10 clean but still getting those errors

Having reverted to v1.4 we’re now seeing some weirdness in the search where half the objects are no longer being returned :frowning: